Gradle 1.10 cannot resolve org.jboss.arquillian.container:arquillian-weld-se-embedded-1.1:1.0.0.CR7


(jianbao.tao) #1

gradle-1.10 cannot resolve a transitive dependency of org.jboss.arquillian.container:arquillian-weld-se-embedded-1.1:1.0.0.CR7, but earlier versions (1.8 and 1.9) can.

You can use this code example to reproduce the problem: https://github.com/JianbaoTao/arquillian-examples/tree/master/greeter.

If you change the wrapper to be of version 1.10, and run

‘’’ ./gradlew clean test ‘’’ You will get something like this: ‘’’ * What went wrong: Could not resolve all dependencies for configuration ‘:testCompile’. > Could not resolve org.jboss.arquillian.container:arquillian-weld-se-embedded-1.1:1.0.0.CR7.

Required by:

com.tao:greeter:1.0-SNAPSHOT

Could not parse POM http://repo1.maven.org/maven2/org/jboss/arquillian/container/arquillian-weld-se-embedded-1.1/1.0.0.CR7/arquillian-weld-se-embedded-1.1-1.0.0.CR7.pom

Unable to resolve version for dependency ‘org.jboss.weld:weld-core:jar’ ‘’’

However, gradle-1.8 and 1.9 do not have any problem.


(Peter Niederwieser) #2

Thanks for the report. Filed as GRADLE-3019.