Grade 4.10.3 does not allow property value to contain space, is that intended?

after upgrading gradle to 4.10.3, I encountered an issue:

gradle 4.10.3 does not allow to have space in the value for a project property. i.e

-P=“value with space”

throw exception.

grade 4.9 does not have this restriction.

is this intended behavior for gradle 4.10.3 or is there bug report for this?

Thanks for any early response.

This is working for me:

task abc {
    doLast {
        println project.getProperty("abc")

$ ~/bin/gradle-4.9/bin/gradle -Pabc="with space" abc -q
with space
$ ~/bin/gradle-4.10.3/bin/gradle -Pabc="with space" abc -q
with space

Thanks Chris.

That leaves us with mystery environment issue then since the same command runs ok with 4.9, but failed with 4.10.3 with error:

xxx/gradlew --init-script xxx/init.gradle -i -s -Dorg.gradle.daemon=false -b build.gradle runCommand -Pcommand=“upgrade --set version=2”


org.gradle.cli.CommandLineArgumentException: Unknown command-line option ‘–set’.

Caused by: org.gradle.cli.CommandLineArgumentException: Unknown command-line option ‘–set’.

[Gradle failure report] at org.gradle.cli.CommandLineParser$BeforeFirstSubCommand.onStartOption(

[Gradle failure report] at org.gradle.cli.CommandLineParser.parse(

[Gradle failure report] at org.gradle.execution.commandline.CommandLineTaskConfigurer.configureTasksNow(

With 4.10.3, if I changed the command to be:
xxx/gradlew --init-script xxx/init.gradle -i -s -Dorg.gradle.daemon=false -b build.gradle runCommand -Pcommand=“upgrade;–set;version=2”

then there is no command parse error.

I am puzzled now. Any suggestion to how to debug?


I am having this issue with -D. When I say:

gradle -DDEBUG="not Debug"

gradle tries to run the task Debug.

Does the following work for you?

gradle -DDEBUG=\"not Debug\"