Gitignore for parent project getting updated incorrectly?

buildship

(Mukarram Baig) #1

Continuing the discussion from Buildship 1.0.11 is now available:

I have upgraded to 1.0.12.v20160330-1501 and I see the following problem in a multi module project setup.

Whenever a new file is being added to the child project, the parent project’s .gitignore is being updated to ignore the child project completely.

For e.g.:
sample-parent
– sample-child1
– sample-child2

When adding a new file in sample-child2, the .gitignore for sample-parent is getting an additional line as:
/sample-child2

I am not sure if this is a buildship thing about derived resources or a EGit plugin related problem, but I had not seen this problem before IIRC. Let me know if you’d need a repo structure to reproduce the issue, but the problem seems to be unrelated to my specific setup. I would appreciate if someone could confirm/disprove this.

Thanks!


(Stefan Oehme) #2

We are marking those folders as “derived” (to stop duplicates from showing up in “Open Resource”) and EGit has a setting to “automatically ignore derived folders”.

The workaround is to disable that EGit setting. I’ll investigate whether there is another option instead of using “derived” to avoid duplicate resource entries.


(Mukarram Baig) #3

Thanks for the quick reply. I can confirm that changing the setting is helping in avoiding this. We will look forward to the investigation and subsequent fix.

Thanks!


(Stefan Oehme) #4

We will remove the derived flag again. This will lead to duplicate resources in the “Open Resource” view. I have opened Bug 490899 in the platform project to track that. Feel free to up-vote it :slight_smile:


(Donát Csikós) #5

Hi,

Buildship 1.0.13 will be released next week, including this fix. If you want to evaluate you can install the latest milestone build from the following update site:

We appreciate any feedback.