Getting 'unresolved supertypes' error with the upgrade to gradle 4.1


(Android Drew) #1

I just upgraded my project to the gradle 4.1 and now I am getting this error:

    Supertypes of the following classes cannot be resolved. Please make 
sure you have the required dependencies in the classpath: class com.google.android.gms.maps.model.LatLng, unresolved supertypes:
 com.google.android.gms.common.internal.safeparcel.zza class com.google.android.gms.maps.model.PolylineOptions, unresolved supertypes:
 com.google.android.gms.common.internal.safeparcel.zza class com.google.android.gms.maps.model.MarkerOptions, unresolved supertypes:
 com.google.android.gms.common.internal.safeparcel.zza class com.google.android.gms.maps.model.CameraPosition, unresolved supertypes: 
com.google.android.gms.common.internal.safeparcel.zza class com.google.android.gms.location.LocationRequest, unresolved supertypes:
 com.google.android.gms.common.internal.safeparcel.zza class 
com.google.android.gms.location.LocationSettingsRequest, unresolved 
supertypes: com.google.android.gms.common.internal.safeparcel.zza class
 com.google.android.gms.location.LocationSettingsResult, unresolved 
supertypes: com.google.android.gms.common.internal.safeparcel.zza

I deleted my .gradle cache to see if that would resolve the error. No dice and I am not sure what’s going on exactly. It was compiling before the upgrade without issue. Any ideas?