Getting error while flutter build appbundle

Note: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: Some input files use unchecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details.

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':google_sign_in_android:compileDebugJavaWithJavac'.
> warning: source release 1.8 requires target release 1.8

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.    

* Get more help at

Java version we use : jdk-11.0.17
google_sign_in: ^5.4.0

Flutter version 3.7.4
Dart version 2.19.2
• DevTools version 2.20.1

getting error while running cmd flutter build appbundle

please help here

It is interesting that this fails, although it just displays the problem as warning.
But actually, the warning is quite clear, isn’t it?
You try to compile with sourceCompatibility = JavaVersion.VERSION_1_8 and targetCompatibility = JavaVersion.VERSION_1_7 or older and that cannot work, thus compilation fails.

tried with JAVA 11 in sourceCompatibility and targetCompatibility still same error is coming

Then you probably did not set it correctly, for example setting it on the extension while it is overridden on the task.
If you run with --debug you will see the compiler arguments used.