Generation of application.xml broken in ear task of Gradle 1.8


(Johannes Rost) #1

The ear task in Gradle 1.8 generates an ejb module for each subdirectory of the configured ‘appDirName’. This leads to a broken application because those directories normally do not represent a valid ejb module (See the screenshots for an example).

I also tried to use the default project layout with src/main/application. Same result.

The exactly the same buildscript is working correctly with Gradle versions 1.5 and 1.6.


(jesper.holmberg) #2

I have run into the same problem. A build that worked under 1.7 now fails. I get the exact same problem as Johannes, with a module of name META-INF specified in my application.xml.


(danigredler) #3

Same issues here… is there a bug number we can track this under?


(Luke Daley) #4

It’s GRADLE-2926.


(Luke Daley) #5

This should be fixed in 1.9.

The release candidate will be out in the next day or two. Please make sure you test your build with it and confirm that it is fixed.


(Benjamin Muschko) #6

Johannes, would you mind trying it out with the latest nightly build. I want to verify that your use case is covered. In case it doesn’t work, could you provide us with a same project?


(Johannes Rost) #7

I will be able to test the nightly build on thursday.


(danigredler) #8

FYI, 1.9-rc-1 seems to fix this issue for us. Thanks!


(Benjamin Muschko) #9

Thanks for letting us know.


(Johannes Rost) #10

1.9-rc-1 fixes the issue for us too.