Findbugs plugin ignores "ignoreFailures" properties


(Geert Premereur) #1

I migrated from milestone-8 to rc-1 and now my build breaks because the findbugs plugin ignores the setting of the ignoreFailure property (we have some timing tests and running with cobertura is much slower than plain junit).

After quite some fiddling with the source of the plugin, it appears this is due to line 119 in FindBugs.groovy:

if (findbugsResult.bugCount && !ignoreFailures) { it should be

if (findbugsResult.bugCount && !getIgnoreFailures()) {

I’m not an expert on gradle, but it appears this property is now part of a convention object which requires different access than before???


(René Groeschke) #2

Hello geert, thanks for the report. I’ll fix this immediately. for the mean time you can use the following workaround to set the ignoreFailures property for all your findbugs tasks:

tasks.withType(FindBugs){
    ignoreFailures = true
}

(Geert Premereur) #3

Thanks for the quick (!) workaround.


(René Groeschke) #4

I exported this problem as a bug to our jira instance at http://issues.gradle.org/browse/GRADLE-2243


(René Groeschke) #5

this is fixed on master and will be part of gradle 1.1


(Martin Jöhren) #6

Hm, strange, why does the workaround not work for me? I have a root project with several sub projects. Root project does not have any java stuff but all subprojects. When i use ms 9 everything works fine with finbugs and ignoreFailures. But when I am on rc1,2,3 it is not working. I also added the mentioned workaround but that does not help either… I added it like that:

subprojects { Project sub ->
    sub.afterEvaluate { Project p ->
        p.tasks.withType(Compile) { options.encoding = "UTF-8" }
        p.tasks.withType(FindBugs) { ignoreFailures = true }
    }
}

(Martin Jöhren) #7

ok, without afterEvaluate it works…