Failing Tests NoClassDefFoundError

I am having a bit of a problem running some of my tests.

Just on my work computer it fails when running the test. Running the tests on CI (Jenkins) and on other computers the tests runs just fine. I have tried deleting the Gradle Home (~/.gradle), and the Gradle Workspace in (app/.gradle), but still fails.
Running without Gradle Daemon, also tried with it.

If (on my computer) I run the test alone it runs just fine.
./gradlew test --tests MyTest

The problem I am getting is when running all tests: > testMethod() FAILED
    java.lang.NoClassDefFoundError: Could not initialize class

It is only the JUnit 5 tests that fails, but not all JUnit5 tests. The JUnit4 tests works fine.
We have approximately 40% JUnit5 and the rest JUnit4 tests.

All the other tests that are failing are getting the same NoClassDefFoundError, on the same class MyTelemetry.

I cannot create a reproducible test. I don’t understand what can possible be wrong just on my computer, but works on everyone else.

The class is initialised through static method.

public class MyTelemetry {

    private static final MyTelemetry INSTANCE = new MyTelemetry();

    public static MyTelemetry obj() {
        return INSTANCE;

Example of one of the tests that fails. A littble bit of it anyway, The other tests thats fails aren’t using MyTelemetry directly, but indirectly from other classes they are using.

public class TelemetryBrokerTest {

    private MyService myService;

    private MyTelemetry myTelemetry;

    public void setUp() {
        // Init DAO context and services...
        myTelemetry = MyTelemetry.obj();

    public void testMethod() {
        // test and assert something

Same with
Gradle 5.6.2 / JDK 8
Gradle 6.0.1 / JDK 11