Fail to zip the .gitignore and .gitattributes


(Alan Lee) #1

I am trying to zip the the .gitattributes and .gitignore but no matter how i try they are still not exist into the zip.

task packageZip(type:Zip) {

from(’.’) {

include ‘/

include ‘**/.gitattributes’

exclude ‘build’

}

}

I know those two files are default exclude but i have no idea how to set defaultExclude into false. But it fails.

I don’t want to change the gradle setting of the default exclude since it may affect other task. Can you give me a sample?

Thanks

task packageZip(type:Zip) {

from “./”

defaultExclude = “false”

}


(Alan Lee) #2

Any idea ?


(Alan Lee) #3

someone asked me and it works… thanks all http://stackoverflow.com/questions/24691975/gradle-fail-to-zip-the-gitignore-and-gitattributes/24695954#24695954