Error deploying to Maven repo


(andyberry88) #1

I am trying to deploy an artifact into an Artifactory repo and am getting the following error:

“Error was: /var/folders/kf/_sqjflj525s9tq4fk7m7h1480000gp/T/gradle_empty_settings93815327837629105.xml (No such file or directory)”

I’m using 1.0-milestone-3 and have also tried the latest milestone 5 snapshot. I see this both on my Mac (Lion) and in our CI environment running XP. I have had this working before but for some unknown reason I now always see the same issue. I’ve tried reverting back to before it started happening but that doesn’t help.

Any suggestions on what is causing this, when is this temporary file meant to be created? As as workaround can I give Gradle my own empty file to work with and if so how do i do that?


(Luke Daley) #2

Hi Andy,

Are you still seeing this with the final version of m5?


(andyberry88) #3

Hi Luke,

Thanks for your reply. Yes, I’m still seeing this with milestone5.

“[ant:null] Error reading settings file ‘C:\WINDOWS\TEMP\gradle_empty_settings469824629654789531.xml’ - ignoring. Error was: C:\WINDOWS\TEMP\gradle_empty_settings469824629654789531.xml (The system cannot find the file specified)”


(Luke Daley) #4

Hmm, very strange.

Is there anyway you could create a sample project that has this behaviour that you could share? That way I could take a look and see what’s going on.


(andyberry88) #5

While trying to create a HelloWorld project to reproduce this I worked out that I was missing an artifacts definition and I’m not using any plugins that define it. So it looks like its a bad error message and bad configuration.


(Scott Palmer) #6

I’m seeing this with m7

The project applies the ‘maven’ plugin and uploads (http) some zips and a couple jars to artifactory. It uses one root project and two sub-projects (one does the zips, the other does the jars)

This just started happening as I was tweaking & testing the project to get it right.


(Scott Palmer) #7

Maybe this is because my root project doesn’t produce an artifact?


#8

Are you applying the maven plugin to your parent project, or just the sub-projects? (allprojects vs subprojects)


(Scott Palmer) #9

allprojects. Changing it to subprojects fixed it. Thanks. Now if only I can get it to upload a POM… not sure why it isn’t…