Eclipse plugin putting .pom files into classpath

I ran into the same problem as previously discussed on the old forum. Unfortunately, I could not find any follow up on this issue.

In my case, I have tried to include the following dependency in my build:

    compile "org.scalanlp:breeze-natives_2.11:0.11.2"

When I run the Eclipse plugin, it generates a pom entry in the classpath that breaks the build in Eclipse:

        <classpathentry kind="lib" path="/home/mmarcini/.gradle/caches/modules-2/files-2.1/com.github.fommil.netlib/all/1.1.2/f235011206ac009adad2d6607f222649aba5ca9e/all-1.1.2.pom" exported="true"/>

At the moment, I use a workaround from here, but it would be great to fix this in the plugin. I use Gradle 2.3

$ gradle -version

Gradle 2.3

Build time:   2015-02-16 05:09:33 UTC
Build number: none
Revision:     586be72bf6e3df1ee7676d1f2a3afd9157341274

Groovy:       2.3.9
Ant:          Apache Ant(TM) version 1.9.3 compiled on December 23 2013
JVM:          1.8.0_45 (Oracle Corporation 25.45-b02)
OS:           Linux 3.13.0-49-generic amd64