Daemon Process Build Failure


I’m using Eclipse LUNA, installed Gradle, and try to build using Java 1.7 JDK. This has worked in the past for me. However, prime difference is I’m forced to run my windows 7 in a VirtualBox on Linux (Zorin 9). Not sure if that is a contributing factor to the issue.

JAVAHOME is not set in my system variables or Path. I tried adding it to my user variables without any change.

ERROR MESSAGE: The newly created daemon process has a different context than expected. It won’t be possible to reconnect to this daemon. Context mismatch:

Java home is different. Wanted: DefaultDaemonContext[uid=null,javaHome=C:\Program Files\Java\jdk1.7.0_67\jre,daemonRegistryDir=C:\Users\Andrew.gradle\daemon,pid=5132,idleTimeout=null,daemonOpts=-XX:MaxPermSize=256m,-XX:+HeapDumpOnOutOfMemoryError,-Xmx1024m,-Dfile.encoding=windows-1252] Actual: DefaultDaemonContext[uid=b5ae17fc-821a-4638-aa49-487cfbef41c3,javaHome=C:\Program Files\Java\jdk1.7.0_67,daemonRegistryDir=C:\Users\Andrew.gradle\daemon,pid=4844,idleTimeout=10800000,daemonOpts=-XX:MaxPermSize=256m,-XX:+HeapDumpOnOutOfMemoryError,-Xmx1024m,-Dfile.encoding=windows-1252]

Could not execute build using Gradle distribution ‘https://services.gradle.org/distributions/gradle-2.0-bin.zip’.

Thanks in advance!