Cpp plugin - platforms not showing in build tasks

I updated to Gradle 2.11 and updated my scripts to reflect the latest
changes. I am using the cpp plugin and I have 4 flavors, 2
buildtypes and 10 platforms. When I run gradle tasks though I don’t see
the option to build for specific platforms any more. I get the
componentBuildTypeFlavorLibrarytype rules but nothing including the
platforms. I know this is normal behavior when it can’t find more than
one platform to build but I am on linux and at the very least
should see 32 and 64 bit platform options (as well as various cross compilers I have installed).

Going back in versions I see that I started adding the specific flavors
and platforms to each component (to down-select my options) which does work but defeats the
flexibility so I would rather not do that if I can help it.

I had a nightly build version of 2.2 (gradle-2.2-20140916220025+0000)
that worked correctly but anything after that seems to behave the same
(not giving platforms without explicitly listing them in each component.
Have I broken my configuration somehow or is this normal behavior?