Could not resolve all files for configuration ':runtimeClasspathCopy'

G’day,

I’m trying to prepare eclipse and forge so that I can write a small plugin. I’m following Home - Forge Documentation as well as Setting up the Workspace - Minecraft Forge 1.16.4 Modding Tutorial - YouTube, but in the many times I have run gradlew genEclipseRuns in the command prompt from the correct directory, I get this:

FAILURE: Build failed with an exception.

  • What went wrong:
    Could not resolve all files for configuration ‘:runtimeClasspathCopy’.

Could not find net.minecraftforge:forge:1.16.5-36.2.39_mapped_official_1.16.5.
Searched in the following locations:

  • file:/C:/Users/Jack Harrington/.gradle/caches/forge_gradle/bundeled_repo/net/minecraftforge/forge/1.16.5-36.2.39_mapped_official_1.16.5/forge-1.16.5-36.2.39_mapped_official_1.16.5.pom
  • file:/C:/Users/Jack Harrington/.gradle/caches/forge_gradle/bundeled_repo/net/minecraftforge/forge/1.16.5-36.2.39_mapped_official_1.16.5/forge-1.16.5-36.2.39_mapped_official_1.16.5.jar
    Required by:
    project :

I have noticed that there is not a bundeled_repo folder in forge_gradle by default, but there is a forge-1.16.5-36.2.39_mapped_ official_1.16.5.pom under minecraft_user_repo instead. If I copy this file to a folder called bundeled_repo that I create (including the child directories), the error still appears.

The video I mentioned suggests to run gradlew genEclipseRuns --refresh-dependencies&&gradlew eclipse, but that throws the exact same error.

There will be a sister post on the forge forums asking the same question.

If you need anything else just ask.

Thanks.

OK, this worked.

I think the issue was installing Adoptium on my D drive, not C:.

Thanks