"Could not get unknown property 'ndkVersion' for extension 'flutter' of type FlutterExtension"

Hello Community,

I have been trying to test my flutter app with an ios / android instance. Every time I try to build the package I get this error:
Could not get unknown property ‘ndkVersion’ for extension ‘flutter’ of type FlutterExtension

Am I missing something?

This is primarily a community for the Gradle build tool, not Flutter. You really need to provide more context about what you have since the core Gradle community hasn’t necessarily ever used Flutter and you’re asking about something built on top of something that is built on top of something else that uses Gradle.

That said, it sounds like you probably added something that was supposed to be Android’s ndkVersion in a flutter block when flutter doesn’t support that particular property in that location.