Could not find com.github.unsplash:unsplash-photopicker-android:1.0.1

Hello everyone!
I was trying to make a new project starting with dependencies when I got this:

1: Task failed with an exception.
* What went wrong:
Execution failed for task ':app:checkDebugAarMetadata'.
> Could not resolve all files for configuration ':app:debugRuntimeClasspath'.
   > Could not find com.github.unsplash:unsplash-photopicker-android:1.0.1.
     Searched in the following locations:
     Required by:
         project :app

I tried to implenment this library as mentioned here:, so I also included maven repo like this:

repositories {
        maven { url '' }

I have no idea why this error occured and would be happy if you can help me!

You probably added JitPack to the wrong place.
As you can see from the error message it was only searched in the Google repo and Maven Central, but not in JitPack.

Btw. you should exclusively use JitPack as last option in the list and imho always with a repository content filter.
JitPack is broken by design, and slow, and unreliable.
Like you have it each and every dependency is first searched in JitPack which is a bad idea imho. :slight_smile:

I tried to use JitPack as the last option (as you said), I also tried to use another repos which could contain this lib, but nothing gives me the result I want.
How should I use JitPack “the right way”?

I’m no psych, I don’t know how you build scripts look like.
As I said, you are most probably adding it at the wrong place, as the error message shows that it didn’t even look at JitPack.
The hint with the order and the repository content filter are just additional improvement suggestions.