Copying plugins to GRADLE_HOME/lib/plugins does not work in Milestone-8 snapshot version


(ruediger.schobbert) #1

I would like to try the Milestone-8 snapshot, but right now I can’t get it to work. The core works just fine, but trying to call custom plugins which were added to the lib/plugins directory cannot be found. Gradle tells me:

Plugin with id ‘artifactory’ not found.

Before Milestone-8 snapshot I used Milestone-3, and there this mechanism worked fine. Just copy some custom plugin to the lib/plugins directory and I could use it from my build scripts.

I am not sure if it has something to do with an old version (the m3 one) being on my computer…

I am using jdk 1.6.0_29 on a windows 7 64bit.

I also tried with Milestone-7, which seems to have the same problem.

Has anyone else encountered this behaviour? Or is this functionality not supported anymore?


(ruediger.schobbert) #2

Ok, just found another forum entry which states exactly the same problem:

http://forums.gradle.org/gradle/topics/using_custom_plugin_templates

So I personally find it quite sad, that this behaviour has vanished…


#3

M3 was the last version to support adding custom plugins to lib/plugins. You now need to declare a dependency on your plugin in a ‘buildscript’ block.

The custom plugins chapter of the user guide has a pretty good treatment of how to manage and share custom plugins. Let us know if it doesn’t help you upgrade to Milestone8.