Com.gradle.enterprise requirement when compiling Java 17 with Gradle 7.3.3

Hello, we are currently migrating our Project to Java 17

For this I upgraded the Gradle version to 7.3.3. Since this I get the following error when trying to build:

Plugin [id: 'com.gradle.enterprise', version: '3.7', artifact: 'com.gradle:gradle-enterprise-gradle-plugin:3.7'] was not found in any of the following sources:
- Gradle Core Plugins (plugin is not in 'org.gradle' namespace)
- Plugin Repositories (could not resolve plugin artifact 'com.gradle:gradle-enterprise-gradle-plugin:3.7')

gradle-enterprise-gradle-plugin doesn’t seem to be referenced anywhere in the Gradle file.

Where does this come from? Why do Gradle needs this now?

Due to cooperate reasons I am currently not able to retrieve new libraries through Nexus (or Maven Central). How can I bypass this requirement or load the jar locally without the need to retrieve it via an online repository?

I tried Gradle 7.2, it seems to throw the same error.

Hi, I am facing the same issue using Java 17 and Gradle 7.5.1. Were you able to resolve this issue? What was the cause? Any update would help.

Afair it is only auto-applied if you use the --scan option.