CertificateExpiredException: NotAfter: Tue Aug 28 14:00:00 CEST 2018


(Krzysztof Szymko) #1

Hi,

I have just updated my local Gradle from 4.9 to 4.10.
As my project is build with Gradle and using Grails, I have changed:

  • gradle\wrapper\gradle-wrapper.properties
    distributionUrl=https://services.gradle.org/distributions/gradle-4.10-bin.zip
  • gradle.properties
    gradleWrapperVersion=4.10

and run gradle from CLI:
gradle --stacktrace

I got:

    ... 186 more
    Caused by: sun.security.validator.ValidatorException: PKIX path validation failed: java.security.cert.CertPathValidatorException: validity check failed
    ... 201 more
    Caused by: java.security.cert.CertPathValidatorException: validity check failed
    ... 201 more
    Caused by: java.security.cert.CertificateExpiredException: NotAfter: Tue Aug 28 14:00:00 CEST 2018
    ... 201 more

since my build.gradle is using:

maven {
    url 'https://repo.grails.org/grails/core'
}
maven {
    url 'https://repo.grails.org/grails/plugins'
}

I have checked site’s certificates and indeed:

SSL Certificate is expired.

The certificate was valid from 24/Aug/2015 through 28/Aug/2018.

The problem which I have now:
I can not build the project till SSL certificate will be renewed
since I also completely deleted %USER%.gradle directory, so
reverting to Gradle 4.9 is also futile.

Should not be an option in Gradle to allow for:
a) temporal allowing untrusted / expired certificates
b) bypass SSL handshake at all

If there is such an option please share it with me since I could not find one.

Chris


(Eric Traub) #2

Having the same issue. Is there a mirror?


(Eric Traub) #3

There is chatter about it in there slack channel: https://grails.slack.com. They don’t have a time estimate on the fix but the maintainers are aware of it and working on it.


(Eric Traub) #4

@kszymko The fixed the cert. You shouldn’t have more issues.