Can't deploy buildship imported web app projects to server in eclipse

buildship

(Steve Cohen) #1

Continuing the discussion from WebApps built with Gradle/Buildship do not show up as deployable in Eclipse Add/Remove:

This is the same issue I raised several weeks ago. No one responded and I am reissuing it as a bug this time as one of the developers on my team has also run into the same issue. The workaround appears to be, after import, manually converting it to a Faceted Project and adding the Dynamic Web App facet. But this is something that Buildship ought to take care of. Running webapps on a local server in Eclipse is a common use case.


Coexist with Maven? Looking for a strategy
(Steve Cohen) #2

It seems that a possible answer is along these lines:

Starting with a non-deployable imported project with the eclipse-wtp plugin applied:

If I run the tasks eclipseWtpComponent and eclipseWtpFacets and then manually convert the project to Faceted form, the project becomes deployable.

I am not sure that all these steps are necessary, and this is still not ideal. In particular, the eclipseWtpFacet task should probably also enable Faceted form, besides its stated “Generates the Eclipse WTP facet settings file” functionality. The Eclipse User most likely couldn’t care less about these files, in fact, the default Eclipse setting is not to even show them to the user. The User wants only to deploy his webapp on a server running in Eclipse and the Gradle tasks should be oriented that way, both in how functionality is packaged, how it works when importing project, and in documentation.

But at least this is a start.

As my colleague says, “I shouldn’t have to be an Eclipse guru to run Gradle.” I agree with him.


(Stefan Oehme) #3

WTP support is coming, read more here: [Request for feedback] WTP support coming to Buildship