Buildship importing of gradle projects failed with Gradle 2.4

After upgrading to Gradle 2.4 (from 2.3) and recreating Eclipse .project/.classpath files, I tried to import the projects into Eclipse Luna. After the first failure I updated also my milestone installation of buildship. But this didn’t solve the problem. With Gradle 2.4 and buildship 1.0.0.v20150417-1028-m, it isn’t possible to import my projects.

This is the error message:

Loading the project preview failed.
Could not fetch model of type ‘GradleBuild’ using Gradle installation ‘D:\java\gradle-2.4’.
Most likely the model of that type is not supported in the target Gradle version.
To resolve the problem you can change/upgrade the Gradle version the tooling api connects to.

I successfully reproduced the problem you described, thank you very much for reporting it! The root cause is the Tooling API module mismatch between Gradle 2.4 and Buildship. I released a new milestone version, so if you perform an update using the site it should work again for you.

1 Like

Hi Donát,
I upgraded the buildship milestone and retried. Yes, now it works. Thanks!