Build when pointing to new nexus Server fails with org/gradle/language/jvm/internal/DefaultResourceSet works with old nexus repo

07:35:33.076 [DEBUG] [org.gradle.configuration.project.BuildScriptProcessor] Timing: Running the build script took 7.861 secs 07:35:33.093 [ERROR] [org.gradle.BuildExceptionReporter]

07:35:33.094 [ERROR] [org.gradle.BuildExceptionReporter] FAILURE: Build failed with an exception. 07:35:33.095 [ERROR] [org.gradle.BuildExceptionReporter]

07:35:33.096 [ERROR] [org.gradle.BuildExceptionReporter] * Where: 07:35:33.096 [ERROR] [org.gradle.BuildExceptionReporter] Build file ‘/spfs/tomcat/.jenkins/workspace/devre01-test/build.gradle’ line: 62 07:35:33.097 [ERROR] [org.gradle.BuildExceptionReporter]

07:35:33.098 [ERROR] [org.gradle.BuildExceptionReporter] * What went wrong: 07:35:33.099 [ERROR] [org.gradle.BuildExceptionReporter] A problem occurred evaluating root project ‘dpfs’. 07:35:33.100 [ERROR] [org.gradle.BuildExceptionReporter] > org/gradle/language/jvm/internal/DefaultResourceSet 07:35:33.101 [ERROR] [org.gradle.BuildExceptionReporter]

07:35:33.101 [ERROR] [org.gradle.BuildExceptionReporter] * Try: 07:35:33.102 [ERROR] [org.gradle.BuildExceptionReporter] Run with --stacktrace option to get the stack trace.

07:35:33.104 [LIFECYCLE] [org.gradle.BuildResultLogger]

07:35:33.105 [LIFECYCLE] [org.gradle.BuildResultLogger] BUILD FAILED 07:35:33.106 [LIFECYCLE] [org.gradle.BuildResultLogger]

07:35:33.107 [LIFECYCLE] [org.gradle.BuildResultLogger] Total time: 13.307 secs

Can you provide more details about the build file and provide the output of the build when running with --stacktrace


I have tried to use the gradle 1.2 to 2.2 nothing works and it gives the same error, i am not getting what the error is. I have tested the maven and any dependency artifacts it is able to download from the failed nexus repository, it is only failing for gradle.

It seems that you are using a grails plugin that uses invalid internal api that is no longer supported. which grails plugin (group:name:version) are you using?

classpath ‘org.grails:grails-gradle-plugin:2.1.1’ this is the one we are using the grails framework is grailsVersion = ‘2.4.0’ when i tried with the old nexus repository it works fine and after successful build which i point to new nexus repository it fails.