Android Studio Many gradle Bugs

Hey guys I have many many bugs in AS :confused:

Hi Guys I took the project I am developing at my workplace home and wanted to run it here on my machineā€¦

I got many many errors wich I fixxed but there are some that I dont know how maybe you guys know a fixx.


this output get generated when building the project from AS.

I read that the fixx is to add this : android.enableBuildCache=false to but when I do that I get this error wich make 0 sense tbh.

: Cannot parse project property android.enableBuildCache='false ' of type 'class java.lang.String' as boolean. Expected 'true' or 'false'.

EDIT: Ok there was an empty space after false hence the second error but even with that corrected I get the first error.

Running it from vsCode gives me: Execution failed for task ':app:processDebugResources'.

EDIT2: Newest Error in AS:

> Task :app:mergeExtDexDebug
java.nio.file.NoSuchFileException: C:\Users\Faded\Desktop\Development\React Native\FitnessApp\FitnessApp\android\app\build\intermediates\external_file_lib_dex_archives\debug\out
    at sun.nio.fs.WindowsException.translateToIOException(
    at sun.nio.fs.WindowsException.rethrowAsIOException(
    at sun.nio.fs.WindowsException.rethrowAsIOException(
    at sun.nio.fs.WindowsDirectoryStream.<init>(
    at sun.nio.fs.WindowsFileSystemProvider.newDirectoryStream(
    at java.nio.file.Files.newDirectoryStream(
    at java.nio.file.Files.list(
    at org.gradle.workers.internal.AdapterWorkAction.execute(
    at org.gradle.workers.internal.DefaultWorkerServer.execute(
    at org.gradle.workers.internal.NoIsolationWorkerFactory$1$1$1.create(
    at org.gradle.workers.internal.NoIsolationWorkerFactory$1$1$1.create(
    at org.gradle.internal.classloader.ClassLoaderUtils.executeInClassloader(
    at org.gradle.workers.internal.NoIsolationWorkerFactory$1$1.execute(
    at org.gradle.workers.internal.AbstractWorker$
    at org.gradle.workers.internal.AbstractWorker$
    at org.gradle.internal.operations.DefaultBuildOperationExecutor$CallableBuildOperationWorker.execute(
    at org.gradle.internal.operations.DefaultBuildOperationExecutor$CallableBuildOperationWorker.execute(
    at org.gradle.internal.operations.DefaultBuildOperationExecutor$1.execute(
    at org.gradle.internal.operations.DefaultBuildOperationExecutor.execute(
    at org.gradle.internal.operations.DefaultBuildOperationExecutor.execute(
    at org.gradle.workers.internal.AbstractWorker.executeWrappedInBuildOperation(
    at org.gradle.workers.internal.NoIsolationWorkerFactory$1.execute(
    at org.gradle.workers.internal.DefaultWorkerExecutor$
    at org.gradle.workers.internal.DefaultWorkerExecutor$
    at java.util.concurrent.Executors$
    at org.gradle.internal.concurrent.ExecutorPolicy$CatchAndRecordFailures.onExecute(
    at org.gradle.internal.concurrent.ManagedExecutorImpl$
    at java.util.concurrent.ThreadPoolExecutor.runWorker(
    at java.util.concurrent.ThreadPoolExecutor$
    at org.gradle.internal.concurrent.ThreadFactoryImpl$

> Task :app:transformClassesWithDexBuilderForDebug
> Task :app:validateSigningDebug UP-TO-DATE
> Task :app:signingConfigWriterDebug
> Task :app:mergeDebugJavaResource
> Task :app:mergeExtDexDebug FAILED

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':app:mergeExtDexDebug'.
> A failure occurred while executing$ActionFacade
   > java.nio.file.NoSuchFileException: C:\Users\Faded\Desktop\Development\React Native\FitnessApp\FitnessApp\android\app\build\intermediates\external_file_lib_dex_archives\debug\out

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

* Get more help at

Deprecated Gradle features were used in this build, making it incompatible with Gradle 7.0.
Use '--warning-mode all' to show the individual deprecation warnings.

150 actionable tasks: 147 executed, 3 up-to-date

It is fixxed for now! ~ Faded.

Hey! I have the same error with app:mergeExtDexDebug. How did you solve that? Thanks for help

@Sultan - check out the answer someone gave me here:

I deleted the directory ./gradle at project and it worked for me. Seems problem was at local build cache.