522 Origin Connection Time-out

Hi, when I’m downloading some artifacts from plugins.gradle.org, I’m getting random timeouts. It started yesterday, sometimes it’s working sometimes not, for different artifacts. Tried from several locations. Could you please help to identify issues? Isn’t the problem with availability of your repo?

curl -L https://plugins.gradle.org/m2/com/adarshr/gradle-test-logger-plugin/2.0.0/gradle-test-logger-plug in-2.0.0.pom

522 Origin Connection Time-out

522 Origin Connection Time-out


Same here. 4 from 5 builds end up with failure due to 522. I’ve tried use old plugins definition, new plugins definitions, different gradle versions. Also I tried to define pluginManagement in settings.gradle, but without any luck.

Example of non-working link: https://plugins-artifacts.gradle.org/gradle.plugin.com.google.cloud.tools/jib-gradle-plugin/2.6.0/3666f6366b18c7b1f2bb5234cabfbb7b51210bc39c1beff90b04009897d73c5b/jib-gradle-plugin-2.6.0.jar
Plugin is defined by id 'com.google.cloud.tools.jib' version '2.6.0' in plugins {} section.
Any help is appreciated.

We’ve got similar issues with our ci pipelines erroring out with Read timed out. Reproducing it locally with curl, it somethimes works with a huge delay (16 seconds) or completely times out with an 522 response.

Here are some urls causing this issue:

  • https://plugins-artifacts.gradle.org/org.asciidoctor/asciidoctor-gradle-base/3.2.0/3dba4017471358c83784cf76a67ee3da6357956cace5345f85d3762f3949c35f/asciidoctor-gradle-base-3.2.0.pom
  • https://plugins-artifacts.gradle.org/io.spring.gradle/dependency-management-plugin/1.0.9.RELEASE/731b162c5ed16870a668e24b781c74075123d3ef03e65b0447fb0b353809fbd2/dependency-management-plugin-1.0.9.RELEASE.pom
  • https://plugins-artifacts.gradle.org/org.springframework.boot/spring-boot-gradle-plugin/2.2.7.RELEASE/f4b5225be9689e921666dc1a45ac1ec6022e3fcd0da0565e5b3d76113e7de1fd/spring-boot-gradle-plugin-2.2.7.RELEASE.pom

Did you find any solution for this problem?

No, issue still exists.
My suspicion is CloudFlare cache problem, but their status is all green (https://www.cloudflarestatus.com/).
I’d expect that gradle team monitors the functionality of their CloudFlare caching solution and might be provide some answer.

Same here, gradle build failing 50/50 with random package failure.

like today 26 Oct 2020 at 14:45:28 CET
Could not resolve gradle.plugin.com.gorylenko.gradle-git-properties:gradle-git-properties:1.4.16.
> Could not get resource ‘https://plugins.gradle.org/m2/gradle/plugin/com/gorylenko/gradle-git-properties/gradle-git-properties/1.4.16/gradle-git-properties-1.4.16.pom’.
> Could not HEAD ‘https://plugins-artifacts.gradle.org/gradle.plugin.com.gorylenko.gradle-git-properties/gradle-git-properties/1.4.16/e143b8d85d9b0cf44fbe37508fc8599d92b694e78b2b4dac571114c2ad0285c5/gradle-git-properties-1.4.16.pom’.
> Read timed out

It looks like those issues have stopped for now, at least from my point of the internet.

Thanks Stefan Kollmann,
I checked it as well and also for me it looks ok. 10 tries, fast responses.
I see the difference in used CloudFlare datacentre, when compared the "curl -L -v " output.
Now I see in response “CF-RAY: 5ec6a99ec89e27a0-PRG”. Originally (when we had issues) there was “CF-RAY: 5e6abf5d2b08f9e6-PRG”.
I’m not sure if that was the issue, I’ll observe this for couple of more days.

1 Like