Trying to install Spinnaker but get `Could not resolve all dependencies for configuration` when attempting to run `./gradlew clean packDeb`


(Jaron King) #1

I am in the process of installing Spinnaker via these instructions, http://www.spinnaker.io/docs/hello-spinnaker but receive the following error when I run the build. Any help would be greatly appreciated!

+ ./gradlew clean packDeb

FAILURE: Build failed with an exception.

* What went wrong:
A problem occurred configuring root project 'hello-karyon-rxnetty'.
> Could not resolve all dependencies for configuration ':classpath'.
   > Could not resolve gradle.plugin.nl.javadude.gradle.plugins:license-gradle-plugin:0.12.1.
     Required by:
         :hello-karyon-rxnetty:0.1.0
      > Could not resolve gradle.plugin.nl.javadude.gradle.plugins:license-gradle-plugin:0.12.1.
         > Could not get resource 'https://plugins.gradle.org/m2/gradle/plugin/nl/javadude/gradle/plugins/license-gradle-plugin/0.12.1/license-gradle-plugin-0.12.1.pom'.
            > Could not GET 'https://plugins.gradle.org/m2/gradle/plugin/nl/javadude/gradle/plugins/license-gradle-plugin/0.12.1/license-gradle-plugin-0.12.1.pom'.
               > peer not authenticated
   > Could not resolve com.netflix.nebula:gradle-ospackage-plugin:3.1.0.
     Required by:
         :hello-karyon-rxnetty:0.1.0
      > Could not resolve com.netflix.nebula:gradle-ospackage-plugin:3.1.0.
         > Could not get resource 'https://plugins.gradle.org/m2/com/netflix/nebula/gradle-ospackage-plugin/3.1.0/gradle-ospackage-plugin-3.1.0.pom'.
            > Could not GET 'https://plugins.gradle.org/m2/com/netflix/nebula/gradle-ospackage-plugin/3.1.0/gradle-ospackage-plugin-3.1.0.pom'.
               > peer not authenticated