resourceException: could not get resource "https//repo.gradle.org

Upgraded from 7.3 to 8 and found this issues started in 7.4. So 7.4 something changed. I used an internal maven repo, so was not surprise when I saw this:

Caused by: org.gradle.api.resources.ResourceException: Could not get resource JFrog

The system will be unable to access repo.gradle.org, put it back to 7.3 all is well again. Must be some configuration I am missing. So what changed that so it uses repo.gradle rather than our custom one?

FYI : In settings.gradle I point to where we keep our artifacts and equally in the build.gradle.

Did you define your custom repo as plugin repository in all your settings scripts? Can you show a build --scan?

We use the standard

repositories {
    maven {
        url "http://repo.mycompany.com/maven2"
    }
} 
using our URL, not sure if that is what you mean.  this is defined in Settings & Build .gradle please explain incase i am missing something

So looking into this more, I use intellij and the issue is when you reload the model. Or use load gradle changes. That is when I get the issue. If I just call build it works!

That sounds strange. When you say “call build”, do you mean from IJ? So you have delegated build to Gradle, or do you use the IJ builder? Can you build from command line?

I can build from the terminal, after which I equally can build from IJ, but if I let IJ to reload the project or update due to gradle changes then gradle has this issue. Not sure if IJ is using a terminal command but if happen it know it I will try. I did try gradle init incase that was used to reload, but that worked fine. I am debugging gradle and can see it finds our repo just fine. Just not when doing a re-load.

It uses the tooling API that then talks to a daemon, just like the command line client basically. It should not behave differently when invoked from IntelliJ. If it does, you should probably open an issue in YouTrack.