My recommendation is to use =, for no other reason than consistency and readability. I like to set my properties with = so it’s clear I’m not trying to call a method (makes it easier for people to translate between groovy dsl and javadoc IMO).
The method is dynamically added by some Gradle magic at runtime. If you’ve ever printed out the class names of many objects you’ll see that their classnames are something like Abc_Decorated, where Abc is the original class. These decorated classes fill in some of the dsl blanks.
If you’re interested in the gory details, here’s a place to start. I’m not familiar with this code so that’s about all I can help with.