Phrasal un-installable in Stanford CoreNLP 3.7.0 by using Gradle 3.5 (but an obligation)


(Daniel Lamontagne) #1

strong text

Phrasal un-installable in Stanford CoreNLP 3.7.0 by using Gradle 3.5 (but an obligation).

1st problem message:
It is impossible to install (Phrasal) in (Standford CoreNLP 3.7.0) by using (Gradle 3.5) which searches (JDK 1.8.0) for a (tool.jar) file which doesn’t exist.

Message: Build Failed.
Due to: cannot find tool.jar (in JDK 1.8.0)

2nd problem message:
(First - for Windows - I have to create a .bat file by doing the following - in CygWin prompt):

$ gradle startupScripts

but it didn’t work

then tried:

$ gradle startScripts

Full Message:
The Task.leftShift(Closure) method has been deprecated and is scheduled to be removed in Gradle 5.0. Please use Task.doLast(Action) instead.
at build_5atc02wj03iy8tfvu5pqi7nvi.run(C:\stanfordcorenlp370\MyDocs-Learn\Phrasal\phrasal-master\build.gradle:96)
:compileJava
:compileJava - is not incremental (e.g. outputs have changed, no previous execution, etc.).
:compileJava FAILED

FAILURE: Build failed with an exception.

  • What went wrong:
    Execution failed for task ‘:compileJava’.

Could not load class 'com.sun.tools.javac.api.JavacTool

  • Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

BUILD FAILED

Total time: 7.433 secs

Conclusion:
There seems to be an incompaibility issue between Gradle 3.5 and JDK 1.8.0.

Possible solution would be to try an older version of JDK (like 1.6) which has the tool.jar in it but haven’t tried it yet.
OR
an older version of Gradle with JDK 1.8.0

Has anyone had this issue and knows the solution to install Phrasal in Stanford CoreNLP with Gradle?

Thanks in advance.