Gradle configuration cache - ‘Gradle.addListener’ is unsupported

Hello,
I’m trying to use gradle configuration cache. For now we have problems with “registration of listener on ‘Gradle.addListener’ is unsupported” on lot of plugins. I didn’t find much support how to solve this. There’s problem even with com.android.library plugin, so I guess changing something in the plugin itself is not a solution