Gradle build succeeds on MacOSX but fails on Linux with Ivy Descriptor problem


(Ricardo Amador) #1

I am getting an issue that only occurs on Linux (SLES 11 SP3) and not on MacOSX. I am building several gradle projects one of which has and ivy dependency which has required me to put that dependency in other projects which use the first dependency: For example

I have a project ‘projectA’ that uses com.company.cam which has configurations of ‘runtime’, runtime-spring3’ and ‘build’.

Now when I use the jar from projectA in projectB I have to import that same dependency (com.company.cam) due to the configurations.

When I run my build on MacOSX there is no issue. However when I run this build on Linux SLES11 SP3 I get the following error:

ProjectA declares a dependency from configuration ‘default’ to configuration ‘compile’ which is not declared in the descriptor for com.company.cam when building projectB.

I am at a loss here as this works fine in one environment and not the other. Any help is appreciated.


(Ricardo Amador) #2

I found the issue with my project. One was a difference in gradle versions being used and the other was to turn off transitive dependencies in a project that had the dependency already.