Gradle 1.12-rc-2 fails with UnsatisfiedLinkError on some Linux versions

I had the same issue, that was caused by the usage of a 32bit JDK on a 64bit Linux installation. Using a 64bit JDK resolved the issue.