FYI Jdepend does not support Java 8

A heads up to the good folks at Gradleware that the Jdepend tool does not currently support Java 8. Unfortunately, it looks like the project is abandoned (i.e. last commit was November 2010). There is a patch available for Java 8 attached to issue #7 opened in June 2014 but it has not been merged or even commented upon by the project owner. I mention all this because Gradle users of the JDepend plugin will get subtle error messages such as “[ant:jdependreport] Unkown constant: 18”, a truncated report, and may report this to Gradleware as a Gradle bug.

1 Like

Thanks for reporting this Baron.