I’m following the tutorials on developing Gradle plugins and I have my basic framework finally working. However I have a design question.
Is it good design practice to have ONE class to perform ONE task action? For example, if I want to develop a plugin to set/get the
version=1.0.0 variable in a
gradle.properties file of a project, should I have my plugin class instantiate TWO different objects, say a
VersionReader to read the version, and a
VersionWriter to write the version? Or can I combine the read/write functions in the SAME
VersionReaderWriter class? If I can combine the functions, how do I designate multiple
@TaskAction functions in the class, and call each one?