Errors in running flutter app

i am getting a lot of errors with running my first flutter app, i think it is related to gradle version, any help please ?