Error listing versions of org.eclipse:text using class org.gradle.api.internal.artifacts.repositories.resolver.MavenVersionLister$1.


(Balusamy N) #1

Hi , I am using gradle 1.10,

i am not using internet but using my own artifactory, while building it is reffering eclipse jar files and trying to connect to internet finaly it is working fine.trying to connect to internet taking more time Can you suggest how to avoid it

Error listing versions of org.eclipse.core:resources using class org.gradle.api.internal.artifacts.repositories.resolver.MavenVersionLister$1. Will attempt an alternate way to list versions. This behaviour has been deprecated and is scheduled to be removed in Gradle 2.0
Error listing versions of org.eclipse.core:runtime using class org.gradle.api.internal.artifacts.repositories.resolver.MavenVersionLister$1. Will attempt an alternate way to list versions. This behaviour has been deprecated and is scheduled to be removed in Gradle 2.0
Error listing versions of org.eclipse.core:filesystem using class org.gradle.api.internal.artifacts.repositories.resolver.MavenVersionLister$1. Will attempt an alternate way to list versions. This behaviour has been deprecated and is scheduled to be removed in Gradle 2.0
Error listing versions of org.eclipse:text using class org.gradle.api.internal.artifacts.repositories.resolver.MavenVersionLister$1. Will attempt an alternate way to list versions. This behaviour has been deprecated and is scheduled to be removed in Gradle 2.0
Error listing versions of org.eclipse.core:expressions using class org.gradle.api.internal.artifacts.repositories.resolver.MavenVersionLister$1. Will attempt an alternate way to list versions. This behaviour has been deprecated and is scheduled to be removed in Gradle 2.0
Error listing versions of org.eclipse:osgi using class org.gradle.api.internal.artifacts.repositories.resolver.MavenVersionLister$1. Will attempt an alternate way to list versions. This behaviour has been deprecated and is scheduled to be removed in Gradle 2.0
Error listing versions of org.eclipse.core:jobs using class org.gradle.api.internal.artifacts.repositories.resolver.MavenVersionLister$1. Will attempt an alternate way to list versions. This behaviour has been deprecated and is scheduled to be removed in Gradle 2.0
Error listing versions of org.eclipse.equinox:registry using class org.gradle.api.internal.artifacts.repositories.resolver.MavenVersionLister$1. Will attempt an alternate way to list versions. This behaviour has been deprecated and is scheduled to be removed in Gradle 2.0
Error listing versions of org.eclipse.equinox:preferences using class org.gradle.api.internal.artifacts.repositories.resolver.MavenVersionLister$1. Will attempt an alternate way to list versions. This behaviour has been deprecated and is scheduled to be removed in Gradle 2.0
Error listing versions of org.eclipse.core:contenttype using class org.gradle.api.internal.artifacts.repositories.resolver.MavenVersionLister$1. Will attempt an alternate way to list versions. This behaviour has been deprecated and is scheduled to be removed in Gradle 2.0
Error listing versions of org.eclipse.core:commands using class org.gradle.api.internal.artifacts.repositories.resolver.MavenVersionLister$1. Will attempt an alternate way to list versions. This behaviour has been deprecated and is scheduled to be removed in Gradle 2.0

(Balusamy N) #2

resolved with the below configuration

configurations {
   all*.exclude group:'org.eclipse.core',module:'resources'
   all*.exclude group:'org.eclipse.core',module:'runtime'
   all*.exclude group:'org.eclipse.core',module:'filesystem'
   all*.exclude group:'org.eclipse.core',module:'expressions'
   all*.exclude group:'org.eclipse.core',module:'jobs'
   all*.exclude group:'org.eclipse.core',module:'commands'
   all*.exclude group:'org.eclipse.core',module:'contenttype'
   all*.exclude group:'org.eclipse.equinox',module:'registry'
   all*.exclude group:'org.eclipse.equinox',module:'preferences'
   all*.exclude group:'org.eclipse',module:'osgi'
   all*.exclude group:'org.eclipse',module:'text'
  }

is it possible to add this from groovy so that i can use as a plugin?


(Luke Daley) #3

Hi,

I’m not quite sure what you mean by add this from groovy. Do you just want to wrap that logic up in a plugin? If so, to use across different projects?


(Balusamy N) #4

Hi, I created a plugin because of that the above error coming, in order to avoid i put the configuration in all the build.gradle, is it possible to add the configuration in plugin?

Regards N.Balusamy