CreateStartScripts and JavaExec should have same named parameters

CreateStartScripts uses mainClassName for the main class while JavaExec uses main. Since these both represent the same concept, it seems like they should be named the same.

It would actually be really nice if they shared a similar set of properties. There are a couple that are specific, but most on JavaExec seem like they would be nice to be able to set on CreateStartScript.