Configure on demand doesn't work with task specific args that have a colon in their value


(Thor Kummer) #1

Appearantly the value is taken for project:task if it includes a colon.

./gradlew --daemon --parallel --configure-on-demand suite:crm:deploy --dest tk@localhost:mydir […] FAILURE: Build failed with an exception.

  • What went wrong: Project ‘tk@localhost’ not found in root project ‘crm’.

./gradlew --daemon --parallel --configure-on-demand suite:crm:deploy --dest tk@localhost:mydir

Works


(Peter Niederwieser) #2

I don’t see any difference between the two commands you gave.


(Thor Kummer) #3

Sorry. The one that works should have been

./gradlew --daemon --parallel suite:crm:deploy --dest tk@localhost:mydir

That is, the same minus the configure-on-demand switch.

The built-in task options seem to have the same problem.

./gradlew --configure-on-demand common-utils:dependencyInsight --configuration compile:x --dependency log4j

FAILURE: Build failed with an exception.

  • What went wrong:

Project ‘compile’ not found in root project ‘crm’.

vs

./gradlew common-utils:dependencyInsight --configuration compile:x --dependency log4j

FAILURE: Build failed with an exception.

  • What went wrong:

Configuration with name ‘compile:x’ not found.