Cannot resolve maven dependency for java_cup from maven central


(Andreas Uschold) #1

Hi,

i’m new to gradle and maven, so may be my problem mighty be a bit stupid.

Im trying to include the java_cup parser generator and jflex into a subproject using gradle 1.12.

Here are the dependencies:

dependencies {
   compile
    project(':core')
   compile
    'net.sf.squirrel-sql.thirdparty-non-maven:java_cup:0.11a'
   compile
    'de.jflex:jflex:1.5.1'
}

mavenCentral() is added to the repositories of this project, with the aid of which the jflex dependency can be resolved, the java_cup dependency not, but the java_cup stuff is on Maven Central for sure:

http://central.maven.org/maven2/net/sf/squirrel-sql/thirdparty-non-maven/java-cup/ and http://central.maven.org/maven2/net/sf/squirrel-sql/thirdparty/non-maven/java-cup/ (i think there are two groupIds because someone made a typo; i tried to access both)

When i run gradlew build --info i can see the following output:

Resource missing. [HTTP GET: http://repo1.maven.org/maven2/net/sf/squirrel-sql/thirdparty/non-maven/java_cup/11a/java_cup-11a.pom]
Resource missing. [HTTP HEAD: http://repo1.maven.org/maven2/net/sf/squirrel-sql/thirdparty/non-maven/java_cup/11a/java_cup-11a.jar]

… and the build fails due to unresolved dependencies.

I don’t see any typo in the dependencies nor did google give me any useful advice (I’m not behind a proxy, i cleaned all cachedirs, i checked that the artifact is hosted on maven central, …)

Any ideas what’s wrong here?


(Gary Hale) #2

I think you have a typo - shouldn’t it be java-cup (instead of java_cup)?


(Andreas Uschold) #3

Now i’m ashamed. I didn’t see that for over 3 hours. Thank you Gary, you saved my day!