Android Studio Could not get resource 'https://dl.google.com/dl/android/maven2/com/android/tools/build/gradle/3.1.0/gradle-3.1.0.pom

Android studio 3.1.2+MacbookPro+java 1.8.144

org.gradle.jvmargs=-DsocksProxyHost=127.0.0.1 -DsocksProxyPort=1086
This one can not work!

I also tried set systemProxy to gradle ,but still can not work.Anyone help to solve this problem!Thanks so much!

Sloved this problem by down to Android Studio version to 3.0.1.

Hi, I am having the same issue like you had, I did all of the change but no luck till now. Any one can hlep me into this.

I made settings in HTTP Proxy and also change gradle.settings with proxy settings.
I try with android studio 3.0.1 either of them work for me.

Same problem here
Android studio 3.1.2 + MacbookPro + HighSierra + java 1.8.0_152
This is very annoying that they can not solve it

Same Problem here.

The Solution as follows

and I hope you Enjoy it!

By the way , my github id is MrLeion,it’s my pleasure to follow each other.

23 Likes

Thanks a lot man,
It just worked…You saved my day

After 3 hours of searching you have saved my too, whooo thank you

it worked,thanks!!!

Whats the solution. I dont see them in your reply

that is work…
but it didn’t solve the true problem.

Sorry, i haven’t log in this website for a long time.
my solution is in the picture.
you can get into prefrence view in Android stuido ,and search gradle just like the picture.

my aims is just to make the android studio get local maven repository beacause my computer can access the website maven.google.com.however,my android studio cannot access the file.so I want to solve this problem by setting android studio. hope it will help you.

Worked for me too. Thanks!

Where is the solution??

Settings -> Build … -> Gradle -> Android Studio -> Enable embedded maven repository

2 Likes

thank you dude you are a life savior, i reinstalled android studio and tried evey other thing i can find until this answer.

This method really works!Thank you!!!

Thanks a lot!!!
I spend 4 hours in solving

Tnx for this advice!

thanks a lot man . i try it for 2 days with many proxies and vpns and etc .