Android gradle plugin download systematically Emulator

Hello, I have an issue with gradle in my CI.

I maintain several Android application projects. I’ve set up the CI with GitLab CI which run lint and build the applications. This setup worked well during long time.
During the build, gradle will download missing build tools (Android SDK Build-Tools, Android SDK Platform, etc.). This is the expected behavior.
However, since about two weeks, I noticed that gradle download systematically Android Emulator. I have no instrumented test, and I there is no reason to download emulator.
More strange, when I run a pipeline with a old git tag the behavior changed (the first time (ie: when the git tag was published), gradle did not download Emulator, and now, with the same git tag, gradle download Emulator).

My question is the following : what reason could make gradle download this emulator ?

I think the reason is not in my Dokerfile (because it doesn’t changed), nor in my build.gradle (because it doesn’t changed) nor with the gitlab ci cache (because I tried to clear it).

Thank you in advance

Timothé TIZIO