5.1.1 setBootClasspath issue

Hey,
after updating to 5.1.1 from 4.7 I noticed that issue:

Unable to find method 'org.gradle.api.tasks.compile.CompileOptions.setBootClasspath(Ljava/lang/String;)V'.
Possible causes for this unexpected error include:<ul><li>Gradle's dependency cache may be corrupt (this sometimes occurs after a network connection timeout.)

Worth to mention that network connection is stable on my end.

Hi Damian,

since Gradle 5.0 there is only CompileOptions.setBootstrapClasspath. Please use that method.

You may want to check out the migration guide.

Cheers,
Stefan

Hi Stefan,
i do face the same issue with an libgdx project, after an android studio upgrade (3.4.0) on a macBook.
Actually i don’t know where and how to make the changes in the gradle file(s).

Any hint for me?
Regards, yarnee

Hi, did you found the solution?

Hi @guichazan, i did actually find a solution describes on the libgdx forum, but realised that my moe module uses a not compatible plugin for the build, so i reverted all my changes and restored the previous (3.3.2) Version of android studio. Because major releases always require a refactoring, i’ll wait for the community to adapt the functionality for gradle 5.x and upgrade later !
(PS: here’s the link for the described solution for libgdx: https://www.badlogicgames.com/forum/viewtopic.php?f=11&t=28658&p=112695#p112695)